POJ2492 A Bug's Life 種羣並查集

   A Bug's Life
Time Limit : 15000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 1   Accepted Submission(s) : 1

Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.


Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.


Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.


Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4


Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

[hint]Huge input,scanf is recommended.[/hint]


Source
TUD Programming Contest 2005, Darmstadt, Germany

來源: http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?cid=10969&pid=1002&ojid=0

#include <cstdio>
using namespace std;
#define MAXN 100000+500
struct  LNode
{
    int father;
    int Relation;
    int ancestor;
    int Rank;
};
LNode Animals[MAXN];
void Init(int n)
{
    for (int i = 1;i <= n;i++)
    {
        LNode &Ani = Animals[i];
        Ani.ancestor = Ani.father = i;
        Ani.Rank = 0;
        Ani.Relation = 0;
    }
}
int f(int a,int b)
{
    if(a==b) return Animals[a].Relation = 0;
    else     return Animals[a].Relation = (Animals[a].Relation + f(Animals[a].father,b))%2;
}
int Find(int x)
{
    LNode &Ani = Animals[x];
    if (Ani.ancestor == x) return x;
    else
    {
        int Real_ance = Find(Ani.ancestor);
        Ani.ancestor  = Real_ance;
        Ani.Relation  = f(x,Real_ance);
        Ani.father = Real_ance;
        return Ani.ancestor;
    }
}
void Unite(int x,int y,int Rx_y = 1)
{
    int X = Find(x), Y= Find(y);
    if (X == Y) return;
    LNode &XL = Animals[X];
    XL.father = XL.ancestor = Y;
    int Ry_Y = f(y,Y);
    int RX_x = (2 - f(x,X))%2;
    XL.Relation = (RX_x + (Rx_y + Ry_Y)%2)%2;

}
int Judge(int X,int Y)
{
    if(Find(X)!=Find(Y))    Unite(X,Y);
    else
    {
        int anc = Find(X);
        int Rx_anc  = f(X,anc);
        int Ranc_y  = (2 - f(Y,anc))%2;
        int D = (Rx_anc + Ranc_y)%2;
        if(!D)   return false;
    }
    return true;
}
int main(void)
{
    //freopen("F:\\test.txt","r",stdin);
    int T;scanf("%d",&T);
    for(int t=1,N,M;t<=T;t++)
    {
        scanf("%d %d",&N,&M);
        Init(N);int flag = 1;
        for(int i=1,a,b;i<=M;i++)
        {
            scanf("%d %d",&a,&b );
            if(!Judge(a,b)) flag = 0;
        }
        printf("Scenario #%d:\n",t);
        if(!flag) printf("Suspicious bugs found!\n\n");
        else      printf("No suspicious bugs found!\n\n");
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章