uvaoj-540:team queue

(小白詳細講解向)//

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.



In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.



Your task is to write a program that simulates such a team queue.

Input
The input file will contain one or more test cases. Each test case begins with the number of teams t ( ). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case

The input will be terminated by a value of 0 for t.



Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output
For each test case, first print a line saying ``Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001


題解:首先奉上從別人博客裏面找到的流程圖:


這道題是劉汝佳白書118頁例題5-6;題目考察的就是對queue知識和少量map知識的理解和運用;

思路就是列多個列隊:

首先是主列隊q,主列隊裏面存放的是分列隊的編號,也可以理解爲指向不同分列隊的指針:因爲不同的元素屬於不同的團隊,每一個團隊的元素在一起構成一個分列隊;這樣方便判斷分列隊是否爲空,以及對分列隊進行處理;

其次是分列隊qq[maxn],分列隊的數目不大於1000,所以使的maxn爲1010,分列隊裏面存放的是具體的元素,也就是成員;

進行插入的時候首先判斷分列隊是否爲空,爲空的話就先在主列隊裏面插入一個指向該分列隊的指針,否則只需在分列隊裏面插入元素即可;

進行出隊操作的時候首先提取出主列隊裏面最前面的指針,在根據指針提取出分列隊,將分列隊裏面的第一個元素pop並打印,在判斷分列隊是否爲空,爲空則刪除指針;

具體代碼如下:


code:-2

#include <iostream>
#include <cstdio>
#include <string>
#include <map>
#include <queue>
using namespace std;
int main()
{
    int n;
    int kase=0;
    while(cin>>n&&n)
    {
        printf("Scenario #%d\n",++kase);

        //
        map<int,int> m;
        for(int i=0; i<n; i++)
        {
            int c;
            cin>>c;
            int x;
            while(c--)
            {
                cin>>x;
                m[x]=i;
            }
        }

        //
        string order;
        queue<int> q,qq[1010];
        while(1)
        {
            cin>>order;
            if(order[0]=='S') break;

            else if(order[0]=='E')
            {
                int x;
                cin>>x;
                int t=m[x];
                if(qq[t].empty())
                q.push(t);
                qq[t].push(x);
            }

            else if(order[0]=='D')
            {
                int t=q.front();
                cout<<qq[t].front()<<endl;;
                qq[t].pop();
                if(qq[t].empty())
                q.pop();
            }
        }
        cout<<endl;
    }
    return 0;
}


筆記:
queue常用函數:
queue<int> q;
q.pop();
q.push(x);
x=q.front();
x=q.back();
q.empty();

stack和queue主要區別就是出進的區別,stack後進先出,queue先進先出;

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章