uvaoj-232:crossword answer

A crossword puzzle consists of a rectangular grid of black and white squares and two lists of definitions (or descriptions).

One list of definitions is for ``words" to be written left to right across white squares in the rows and theother list is for words to be written down white squares in the columns. (A word is a sequence of alphabetic characters.)

To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.

The definitions correspond to the rectangular grid by means of sequential integers on ``eligible" white squares. White squares with black squaresimmediately to the left or above them are ``eligible." White squares with nosquares either immediately to the left or above are also ``eligible." No othersquares are numbered. All of the squares on the first row are numbered.

The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering.

An ``across" word for a definition is written on a sequence of white squares ina row starting on a numbered square that does not follow another white square in the same row.

The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in the row or in the rightmost square of the row.

A ``down" word for a definition is written on a sequence of white squares in acolumn starting on a numbered square that does not follow another white square in the same column.

The sequence of white squares for that word goes down the column of the numbered square, ending immediately before the next black square in the column or in the bottom square of the column.

Every white square in a correctly solved puzzle contains a letter.

You must write a program that takes several solved crossword puzzles as input and outputs the lists of across and down words which constitute the solutions.

Input

Each puzzle solution in the input starts with a line containing two integers rand c ( tex2html_wrap_inline39 and tex2html_wrap_inline41 ), where r (the first number) is the number ofrows in the puzzle and c (the second number) is the number of columns.

The rrows of input which follow each contain c characters (excluding the end-of-line) which describe the solution. Each of those c characters is an alphabeticcharacter which is part of a word or the character ``*", which indicates ablack square.

The end of input is indicated by a line consisting of the single number 0.

Output

Output for each puzzle consists of an identifier for the puzzle (puzzle #1:,puzzle #2:, etc.) and the list of across words followed by the list of downwords. Words in each list must be output one-per-line in increasing order of the number of their corresponding definitions.

The heading for the list of across words is ``Across". The heading for the list of down words is ``Down".

In the case where the lists are empty (all squares in the grid are black), the Across and Down headings should still appear.

Separate output for successive input puzzlesby a blank line.

Sample Input

2 2
AT
*O
6 7
AIM*DEN
*ME*ONE
UPON*TO
SO*ERIN
*SA*OR*
IES*DEA
0

Sample Output

puzzle #1:
Across
  1.AT
  3.O
Down
  1.A
  2.TO

puzzle #2:
Across
  1.AIM
  4.DEN
  7.ME
  8.ONE
  9.UPON
 11.TO
 12.SO
 13.ERIN
 15.SA
 17.OR
 18.IES
 19.DEA
Down
  1.A
  2.IMPOSE
  3.MEO
  4.DO
  5.ENTIRE
  6.NEON
  9.US
 10.NE
 14.ROD
 16.AS
 18.I
 20.A


題解:劉汝佳白書58頁練習題3-6,模擬題,水題,重點在於細心;

分兩個部分,輸入和輸出;

輸入的時候注意給每個位置的方塊進行編碼,我是用getchar進行字符的輸入,這樣可以從1開始進行循環輸入,在判定的時候比較方便;

輸出注意%3d,空行,冒號什麼的,我被一個冒號卡了一個小時,真心悲傷啊;

詳細代碼如下:


code:

#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;
char m[20][20];
int num[20][20];
int main()
{
    int time=0;
    int rows,cols;
    int cnt;
    bool flag=0;
    while(cin>>rows&&rows&&cin>>cols)
    {

        if(flag)
        cout<<endl;
        flag=1;
        memset(m, '*' ,sizeof m);
        memset(num, 0 ,sizeof num);
        cnt=0;
        for(int i=1; i<=rows; i++)
        {
            for(int j=1; j<=cols; j++)
            {
                cin>>m[i][j];
                if((m[i][j-1]=='*'||m[i-1][j]=='*')&&m[i][j]!='*')
                {
                    num[i][j]=++cnt;
                }
            }
        }
        cout<<"puzzle #"<<++time<<':'<<endl;
        cout<<"Across"<<endl;
        for(int i=1; i<=rows; i++)
        {
            for(int j=1; j<=cols; j++)
            {
                if(m[i][j-1]=='*'&&m[i][j]!='*')
                {
                    printf("%3d.",num[i][j]);
                    while(m[i][j]!='*'&&j<=cols)
                    {
                        cout<<m[i][j];
                        j++;
                    }
                    cout<<endl;
                }
            }
        }
        //
        cout<<"Down"<<endl;
        for(int i=1; i<=rows; i++)
        {
            for(int j=1; j<=cols; j++)
            {
                if(m[i-1][j]=='*'&&num[i][j]!=0)
                {
                    printf("%3d.",num[i][j]);
                    int k=i;
                    while(m[k][j]!='*'&&k<=rows)
                    {
                        cout<<m[k][j];
                        k++;
                    }
                    cout<<endl;
                }
            }
        }
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章