uvaoj-400:Unix Is

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.

Input

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (tex2html_wrap_inline41 ). There will then beN lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a toz,A toZ, and0 to9) and from the following set{ ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be theN for the next set or the end of file. You should read and format all sets in the input file.

Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenamesR+1 to 2R listed down column 2; etc.

Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben

Sample Output

------------------------------------------------------------
12345678.123         size-1               
2short4me            size2                
mid_size_name        size3                
much_longer_name     tiny                 
shorter              very_long_file_name  
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky          
Buckwheat      Darla          Mrs_Crabapple  Stimey         
Butch          Froggy         P.D.           Weaser         
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben       
Bobby       Cindy       Jody        Mike        Shirley     
Buffy       Danny       Keith       Mr._French  Sissy       
Carol       Greg        Lori        Peter

題解:劉汝佳127頁例題5-8;考察的是sort排序以及一些小技巧;
題目本身就在於模擬,因爲打印的時候只能從第一行開始向下打印,所以在打印的部分要有些技巧,具體見代碼;
另外題目中的cols指的是colunms,也就是每一行要打印的單詞數;
rows就是指rows,也就是需要打印的行數;

code:
#include <iostream>
#include <cstdio>
#include <string>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int maxn=1050;
int maxx=0;
int main()
{
    int n;
    string s[maxn];
    while(cin>>n)
    {
        maxx=0;
        for(int i=0; i<n; i++)
        {
            cin>>s[i];
            int lens=s[i].size();
            maxx=max(maxx,lens);
        }
        for(int i=0; i<60; i++)
            cout<<'-';
            cout<<endl;
        int cols,rows;
        cols=(60-maxx)/(maxx+2)+1;
        rows=(n-1)/cols+1;
        sort(s,s+n);
        for(int i=0; i<rows; i++)
        {
            for(int j=0; j<cols; j++)
            {

                int dig=j*rows+i;
                if(dig>=n) break;
                cout<<s[dig];
                int len=s[dig].size();
                for(int k=0; k<maxx-len; k++)
                    cout<<' ';
                if(j==cols-1)
                    cout<<"  ";
            }
            cout<<endl;
        }
    }
    return 0;
}

筆記:
cols=(60-maxx)/(maxx+2)+1;
        rows=(n-1)/cols+1;
上邊這兩行:
cols的得出利用了int類型捨去小數部分的特性,最後的+1是加上了最後一行;
rows中也利用了這種特性,(n-1)是爲了避免n和cols恰好整除是多一行,具體來說:假設n和cols不是恰好整除,則餘數部分被直接捨去,結果少一行,因此需要+1,但是如果恰好整除,+1則會多一行,因此(n-1)是一個很好的解決方法;

int dig=j*rows+i;
上邊這一行:
dig類似於一個指針,表格在計算機裏生成是正常生成的,即把答案要求的格式順時針旋轉90°的樣式,因此需要dig來指示打印;





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章