HDOJ-1002大數相加

參考這篇:點擊打開鏈接

 

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.


 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.


 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.


 

Sample Input
2 1 2 112233445566778899 998877665544332211


 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include <iostream>
#include<cstdio>
#include<string>
#include<string.h>
void add(char a[],char b[],char c[]);
int main(int argc, char *argv[]) {	
	int x;
	scanf("%d",&x);
	for(int i=1;i<=x;i++){	
			char a[1005],b[1005],c[1005];
			a[0]=b[0]='0';//數組首位置0,方便最高位進位 
			scanf("%s",&a[1]);
			scanf("%s",&b[1]);
			printf("Case %d:\n",i);	
			add(a,b,c);
			printf("%s + %s = ",&a[1],&b[1]);
			if(c[0]!='0')printf("%c",c[0]);
			printf(i==x?"%s\n":"%s\n\n",&c[1]);
	}
	return 0;
	
}
void add(char a[],char b[],char c[]){
	int lenA,lenB,lenC;
	lenA=strlen(a);
	lenB=strlen(b);
	lenC=(lenA>lenB)?lenA:lenB;//數組c長度爲a,b較長長度。 
	int carry=0,t=0;
	c[lenC]='\0';			//字符串以'\0'做結束標誌。 
	for(int i=lenC-1;i>=0;i--){
		lenA--;
		lenB--;
		if(lenA>=0&&lenB>=0){
			t=a[lenA]-'0'+b[lenB]-'0'+carry;carry=0;//a, b數組的末位開始相加,取其數值做判斷加完進位後carry置0 
			if(t>9){
			c[i]=t-10+'0';//數值大於10 ,取其個位,進位carry置1. 
			carry=1;
			}
			else c[i]=t+'0';			
			}
			
		if(lenA>=0&&lenB<0){// a數組位數較長,將a數組多餘字符賦給c。 
			t=a[lenA]-'0'+carry;carry=0;
			if(t>9){
				c[i]=t-10+'0';
				carry=1;
			}
			else c[i]=t+'0';
			}
		if(lenB>=0&&lenA<0){//b數組較長 
			t=b[lenB]-'0'+carry;carry=0;
			if(t>9){
				c[i]=t-10+'0';
				carry=1;
			}
			else c[i]=t+'0';
		}
	}	
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章