zju1045题解

题目:

HangOver


Time Limit: 1 Second      Memory Limit: 32768 KB


How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.


Example input:

1.00
3.71
0.04
5.19
0.00


Example output:

3 card(s)
61 card(s)
1 card(s)
273 card(s)


 

Source: Mid-Central USA 2001

题目大意:你可以把一叠卡片放的离桌子多远?如果有一张卡片,那么可达到的最远距离是卡片唱的的一半(假设卡片必须与桌子的边缘垂直),是用两张卡片,是上面一张能放到的最远距离超过下面长度的一半,而下面一张超过桌子的是卡片长度的1/3,所以能达到的最远距离是:1/2+1/3=5/6。一半来说,n张卡片能达到的最远距离是1/2+1/3+1/4+....+1/(n+1),也就是最顶上的卡片超出第二张的1/2,第二张超出第三张的1/3,第三张超出第四张的1/4,等等,输入一行数字0.00时表示输入结束,每个测试例一行,是一个浮点数c(0.01<=c<=5.20),c刚好是3位数字。对每个测试例,输出达到距离c所需要的最少卡片的数量。注意输出格式!

算法分析:其实这道题就是1/2+1/3+...+1/(n+1)<=c,利用循环语句知道上面的等式超过c为止。

代码:

语言:c

#include<stdio.h>

int main()

{

float c;

while(scanf("%f",&c)&&c!=0)

{

int i=2;

float result=0;

while(result<c)

{

result=result+1.00/i;

++i;

}

printf("%d card(s)/n",i-2)

}

return 0;

}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章