Truck History POJ - 1789

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 
Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output
For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0
Sample Output
The highest possible quality is 1/3.
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int b[3000][3000],mark[3000],c[3000];
char a[3000][20];
int n;
int chf(int i,int j)
{
    int k;int sum=0;
    for(k=0;k<7;k++)
    {
        if(a[i][k]!=a[j][k])
        {sum++;}
    }
    return sum;
}

int prim()
{
    int i,j,min,s;
    memset(mark,0,sizeof(mark));
    memset(c,0,sizeof(c));
    int k=0;int sum=0;s=0;
    for(i=0;i<n;i++)
    {
        mark[k]=2; min=999999999;
        for(j=0;j<n;j++)
        {
            if(b[k][j]!=-1&&(c[j]>b[k][j]||c[j]==0)&&mark[j]!=2)
            {
                c[j]=b[k][j];
                mark[j]=1;
            }
        if(b[j][k]!=-1&&(c[j]>b[j][k]||c[j]==0)&&mark[j]!=2)
            {
                c[j]=b[j][k];
                mark[j]=1;
            }
        }
        for(j=0;j<n;j++)
        {
            if(c[j]!=0&&c[j]<min&&mark[j]==1)
            {
                min=c[j];
                s=j;
            }
        }
        k=s;
    }
    for(i=0;i<n;i++)
    {
        sum=sum+c[i];
    }
    return sum;
}

int main()
{
    int i,j,ans;
    while(scanf("%d",&n)&&n)
    {

        memset(b,-1,sizeof(b));
        for(i=0;i<n;i++)
        {scanf("%s",a[i]);}

        for(i=0;i<n-1;i++)
        {
            for(j=i+1;j<n;j++)
            {
                b[i][j]=chf(i,j);
                b[j][i]=b[i][j];
            }
        }

      ans=prim();
        printf("The highest possible quality is 1/%d.\n",ans);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章