11-散列2 Hashing   (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSizeTSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSizeMSize (10^4) and N (MSize) which are the user-defined table size and the number of input numbers, respectively. Then NN distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

解析:

散列表長度爲4k+3(k是正整數)形式的素數時,平方探測法能探測到整個散列表的空間。

但是本題給的只是素數,所以有不能探測到位置的情況。

當增量k大於等於size時,平方探測就會重複之前的探測,進入一個死循環。

假設散列表大小爲Size,那麼當增量大於等於Size平方的時候就是在重複之前1平方,2平方...到(size-1)平方的事情。只要把Size平方,(Size+1)平方因式分解一下,就會發現對求餘有影響的就是Size加的部分,後面就是一直重複了。) 參考地址

原理沒看懂,有空再看

#include <iostream>
#include <vector>
#include <cstdlib>
#include <cmath>
using namespace std;
int NextPrime ( int N ) {
	if ( N == 1 ) //1既不是素數,也不是合數; 2是素數
		return 2;
	int i, p = ( N % 2 ) ? N + 2 : N + 1;
	while (1) {
		double q = p;
		for ( i = sqrt(q); i > 2; i-- )
			if ( !( p % i ) ) break;
		if ( i == 2 ) return p;
		else p += 2;
	}
}
int IsPrime ( int n ) {
	if ( n == 1 ) 
		return 0;
	else if ( n == 2 )
		return 1;
	else {
		int k = sqrt(n);
		for ( int i = 2; i <= k; i++ )
			if ( n % i == 0 )
				return 0;
		return 1;
	}
}
int main () {
	int MSize, TSize, N, key, pos, tmp, k;
	cin >> MSize >> N;
	if ( IsPrime( MSize ) )
		TSize = MSize;
	else
		TSize = NextPrime( MSize );
	//用數組建立散列表
	vector<int> v(TSize);
	for ( int i = 0; i < TSize; i++ )  //散列表初始化爲0,方便判斷位置上有無元素
		v[i] = 0;
	//將元素插入散列表並輸出下標
	for ( int i = 0; i < N; i++ ) {
		cin >> key;
		pos = key % TSize;
		k = 0; tmp = pos;
		while ( k < TSize ) {  //k>=size後,平方探測將進入一個死循環
			if ( v[pos] == 0 ) { //如果該位置沒有元素
				v[pos] = key;
				cout << pos;
				break;
			}
			else { //該位置有元素,使用平方探測法解決衝突
				k++;
				pos = ( tmp + k * k ) % TSize; 
			}
		}
		if ( k == TSize ) //沒找到
			cout << "-";
		if ( i != N - 1 ) //最後一個元素後面不要空格
			cout << " ";
	}
	system("pause");
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章