FatMouse' Trade

 FatMouse' Trade

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. 
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000. 
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 
 
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1 
 
Sample Output
13.333

31.500 


題目大意:一隻老鼠要用貓糧和貓交易食物,有n個房間,給出每個房間裏的食物和進入需要的貓糧,第一行兩個數分別表示總共的貓糧數量m和房間數量n,接下來是n行是n個房間裏的食物數量和需要貓糧數量,求老鼠能交換最多的食物數量。

/*
很簡單的貪心題,先按照價值/代價的比值來排序,肯定是先買比值大的。
*/
//AC
#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;
struct data
{
    double j,f,r;
};
bool cmp(struct data a,struct data b)
{
    if (a.r>b.r)
        return true;
    return false;
}
int main()
{
    int m,n;
    while (scanf("%d%d",&m,&n))
    {
        if (m==-1&&n==-1)
            break;
        int i;
        vector<struct data> D(1010);
        for (i=0;i<n;i++)
        {
            scanf("%lf%lf",&D[i].j,&D[i].f);
            D[i].r=D[i].j/D[i].f;
        }
        sort(D.begin(),D.end(),cmp);
        double sum=0;
        for (i=0;i<n;i++)
        {
            if (m>=D[i].f)
            {
                sum+=D[i].j;
                m-=D[i].f;
            }
            else
            {
                sum+=(D[i].j/D[i].f)*m;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章