POJ - 1861 Network

Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 17321
Accepted: 6970
Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

Source

Northeastern Europe 2001, Northern Subregion


題意:
求最小生成樹的最大權值,並輸出經過的邊數和路徑

代碼:
(prime算法)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f

int dis[1005][1005],dist[1005],vis[1005];
int n,m,maxk;
int f[1005];

void prime(){
	int sum=0;
	maxk=0;
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++){
		dist[i]=dis[1][i];
		f[i]=1;//記錄父親節點 
	}
		
		
	vis[1]=1;
	int m=n-1;
	while(m--){
		int minx=INF;
		int p=0;
		for(int i=1;i<=n;i++){
			if(!vis[i]&&dist[i]<minx){
				minx=dist[i];
				p=i;
			}
		}
		vis[p]=1;
		if(p==0)break;
		sum+=minx;
		maxk=max(maxk,minx);
				
		for(int i=1;i<=n;i++){
			if(!vis[i]&&dist[i]>dis[p][i]){
				f[i]=p; //更新父親節點 
				dist[i]=dis[p][i];
			}
				
		}
	}
}

int main(){
	scanf("%d%d",&n,&m);
	memset(dis,INF,sizeof(dis));
	for(int i=1;i<=m;i++){
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		dis[a][b]=dis[b][a]=min(dis[a][b],c);
	}
	prime();
	printf("%d\n%d\n",maxk,n-1);
	
	for(int i=2;i<=n;i++)printf("%d %d\n",f[i],i);
	return 0;
} 

(kruscal算法)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f

int n,m;
int maxk,cnt;
int ax[15000],ay[15000],f[15000];

struct data{
	int x,y,c;
}edge[15000];

bool cmp(data a,data b){
	return a.c<b.c;
}
void pre(){
	for(int i=0;i<=n;i++)f[i]=i;
}

int find(int x){
	return f[x]==x?x:find(f[x]);
}

void kruscal(){
	int sum=0;
	cnt=0;
	sort(edge,edge+m,cmp);
	
	for(int i=0;i<m;i++){
		int x=find(edge[i].x);
		int y=find(edge[i].y);
		if(x!=y){
			maxk=max(maxk,edge[i].c);
			sum++;
			f[x]=y;
			ax[cnt]=edge[i].x;
			ay[cnt++]=edge[i].y;
		}
		if(sum>=n-1)break;
	}
}

int main(){
	scanf("%d%d",&n,&m);
	int a,b,c;
	for(int i=0;i<m;i++){
		scanf("%d%d%d",&edge[i].x,&edge[i].y,&edge[i].c);
	}
	maxk=0;
	pre();
	kruscal();
	
	printf("%d\n%d\n",maxk,cnt);
	for(int i=0;i<cnt;i++){
		printf("%d %d\n",ax[i],ay[i]);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章