HDU 3018 歐拉回路 筆畫數問題

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1567    Accepted Submission(s): 609


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  3013 3015 3016 3011 3010 
 

//
//  main.cpp
//  HDU 3018 歐拉回路
//
//  Created by 鄭喆君 on 8/8/14.
//  Copyright (c) 2014 itcast. All rights reserved.
//

#include<cstdio>
#include<cstring>
#include<iostream>
#include<iomanip>
#include<queue>
#include<cmath>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;
typedef long long LL;
const int int_max = 0x07777777;
const int int_min = 0x80000000;
const int maxn = 110000;
int root[maxn];
int find (int x){
    while(x!=root[x]){
        x = root[x];
    }
    return x;
}
void combine (int x, int y){
    int xx = find(x);
    int yy = find(y);
    if(xx!=yy){
        root[yy] = xx;
    }
}
vector<int> g[maxn];
vector<int> gg[maxn];
int n,m;
int main(int argc, const char * argv[])
{
    while(scanf("%d %d", &n, &m)!=EOF){
        for(int i = 0; i < maxn; i++) {
            g[i].clear();
            gg[i].clear();
            root[i] = i;
        }
        for(int i = 0; i < m; i++){
            int x, y;
            scanf("%d %d", &x, &y);
            g[x].push_back(y);
            g[y].push_back(x);
            combine(x, y);
        }
        int result = 0;
        for(int i = 1; i <= n; i++){
            if(g[i].size()&1) result++;
        }
        result /= 2;

        for(int i = 1; i <= n; i++){
            gg[find(i)].push_back(i);
        }
        for(int i = 1; i<= n; i++){
            if(gg[i].size()){
                int flag = 1;
                for(int j = 0; j < gg[i].size(); j++){
                    if(g[gg[i][j]].size()&1 || g[gg[i][j]].size()==0) {
                        flag = 0;
                        break;
                    }
                }
                if(flag) result++;
            }
        }
        cout << result << endl;
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章