[HDU 1116]Play on Words(歐拉回路/歐拉路徑+並查集)

Description


Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word “acm” can be followed by the word “motorola”. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input


The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number N that indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.

Output


Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.

Sample Input


3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output


The door cannot be opened.
Ordering is possible.
The door cannot be opened.

Solution


大概是說給出一堆單詞判斷能否成語接龍
將26個字母視作點,每輸入一個單詞就是在它的首字母與末字母之間加一條邊,判斷能否構成歐拉回路或歐拉路徑,注意要用並查集判斷是否聯通

*無向圖爲半歐拉圖,當且僅當爲連通圖且除了兩個頂點的度爲奇數之外,其它所有頂點的度爲偶數。
*無向圖爲歐拉圖,當且僅當爲連通圖且所有頂點的度爲偶數。

(可見07年國集論文歐拉回路性質與應用探究

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int T,n,cnt,in[30],out[30],father[30];
char plates[1005];
int getfather(int x)
{
    if(father[x]==x)return x;
    father[x]=getfather(father[x]); 
    return father[x];
}
void add(int x,int y)
{
    int fx=getfather(x),fy=getfather(y);
    if(fx!=fy)
    father[fx]=fy;
}
int main()
{
    scanf("%d",&T);
    int m=0;
    while(T--)
    {
        m++;
        for(int i=1;i<=26;i++)
        father[i]=i;
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        scanf("%d",&n);    
        if(m==2)
        {
        m=2;
        }
        for(int i=1;i<=n;i++)
        {
            cin>>plates;
            int u=plates[0]-'a'+1,v=plates[strlen(plates)-1]-'a'+1;
            out[u]++;
            in[v]++;
            add(u,v);
        }

        bool outf=0,inf=0,f=1;
        int hah=0;
        for(int i=1;i<=26;i++)
        {
            if(in[i]||out[i])
            {
                if(!hah)
                hah=getfather(i);
                else if(getfather(i)!=hah){
                    f=0;break;
                }
            }
            if(in[i]!=out[i])
            {
                if(in[i]==out[i]+1)
                {
                    if(inf){
                        f=0;break;
                    }
                    else{
                        inf=1;
                        if(outf)f=1;
                    }
                }
                else if(in[i]+1==out[i])
                {
                    if(outf){
                        f=0;break;
                    }
                    else {
                        outf=1;
                        if(inf)f=1;
                    }
                }
                else{
                    f=0;break;
                }
            }
        }
        if(f)printf("Ordering is possible.\n");
        else printf("The door cannot be opened.\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章