HDU5001 Walk(概率DP)

A - Walk
Time Limit:15000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling. 

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times. 

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

Input

The first line contains an integer T, denoting the number of the test cases. 

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b. 

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

Output

For each test cases, output n lines, the i-th line containing the desired probability for the i-th node. 

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

Sample Input

2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
 

Sample Output

0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037
//給一個無向圖 , n個節點,m條邊
//每個節點爲起點的概率相同 
//問每個節點走d步後不經過這個節點的概率
//不經過這個節點的概率等於去掉該節點的圖中走了d步到其他節點的和
//dp[i][j] 爲走了i步到達j個節點的概率
//dp[i][j] = segma(dp[i-1][v])/vec[j].size()
#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
using namespace std ;
const int maxm = 10010 ;
const int maxn = 60 ;
double dp[maxm][maxn] ;
double outdegree[maxn] ;
double p[maxn] ;
vector<int>vec[maxn] ;
int main()
{
   // freopen("in.txt" ,"r" , stdin) ;
    int T ;
    int m , n, d ;
    scanf("%d" ,&T) ;
    while(T--)
    {
        scanf("%d%d%d" ,&n , &m , &d) ;
        memset(p , 0 , sizeof(p)) ;
        for(int i = 1;i <= n;i++)
        vec[i].clear() ;
        for(int i = 1;i <= m;i++)
        {
            int a , b ;
            scanf("%d%d" ,&a ,&b) ;
            vec[a].push_back(b) ;
            vec[b].push_back(a) ;
        }
        for(int s = 1;s <= n;s++)
        {
            memset(dp , 0 , sizeof(dp)) ;
            for(int i = 1;i <= n;i++)
            dp[0][i] = 1.0/(double)n ;
            double ans = 0 ;
            for(int i = 1;i <= d;i++)
            for(int j = 1;j <= n;j++)
            {
                if(j == s)continue ;
                for(int k = 0;k < vec[j].size() ;k++)
                {
                    int v = vec[j][k] ;
                    if(v == s)continue ;
                    dp[i][j] += dp[i-1][v]/(double)vec[j].size();
                }
            }
            dp[0][s] = 1.0/(double)n ;
            for(int j = 1;j <= n;j++)
            p[s] += dp[d][j] ;
        }
        for(int i = 1;i <= n;i++)
        printf("%lf\n" , p[i]) ;
    }
    return 0 ;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章