poj 3071 Football (概率DP水題)

G - Football
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2nvalues; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

題目:有2^n個隊,相鄰的兩兩打淘汰賽,,求最後哪個隊奪冠的概率最大。
題解:dp[i][j]表示第i輪的時候,第j去支隊伍贏的概率。那麼dp[i][j]的前提就是i-1輪的時候,
   j是贏的,而且第i輪贏了對方接下來就是找到第i輪的時候,他的可能隊手

   通過二進制可以發現規律,所有高位是一樣的,第i位剛好相反,

   所以用位運算可以巧妙解決,見代碼

   dp[i][j]=sigma(dp[i-1][j]*dp[i-1][k]*p[j][k])

   每經過一輪會淘汰掉一半的人,所以可以右移一位,即除以二求概率。

   具體的解釋請看代碼註釋。O(∩_∩)O

#include <iostream>
#include <string.h>
using namespace std;
double dp[8][200];
double p[200][200];
int main()
{
    int n,ans;
    while(cin>>n)
    {
        if(n==-1)
            break;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<(1<<n);i++)//2^n支隊伍
        for(int j=0;j<(1<<n);j++)
        cin>>p[i][j];
        for(int i=0;i<(1<<n);i++)
        dp[0][i]=1;
        for(int i=1;i<=n;i++) //n次比賽
        for(int j=0;j<(1<<n);j++)//注意這裏跑的核心是j 而且j只跑了一次
        for(int k=0;k<(1<<n);k++)//這裏是左移 代表隊伍數 
        if(((j>>(i-1))^1)==(k>>(i-1))) //這裏是右移 代表每次淘汰一半人
        //這個if的意思是奇數只和上一個數比而偶數只和下一個數比
        //異或一可以讓奇數減一 偶數加一
        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k]; //別忘了加號 是把概率加起來
        double max=-1;
        /*for(int j=0;j<(1<<n);j++)
            cout<<dp[n][j]<<endl;*/ //輸出各隊勝率
        for(int j=0;j<(1<<n);j++) //選擇勝率最高的那個隊伍
        if(dp[n][j]>max)
        {
            max=dp[n][j];
            ans=j+1;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章