poj2342 Anniversary party 題解

Anniversary party
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5158   Accepted: 2925

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int vis[6005];
int dp[6005][2];
int father[6005];
int n;

int max(int a,int b) {
    return (a>b)?a:b;
}

void treedp(int node) {
    int i;
    vis[node]=1;
    for(i=1; i<=n; i++) {
        if(!vis[i]&&father[i]==node) {
            treedp(i);
            dp[node][1]+=dp[i][0];
            dp[node][0]+=max(dp[i][0],dp[i][1]);
        }
    }
}

int main() {
    int l,k,i;
    scanf("%d",&n);
    int root=0;
    for(i=1; i<=n; i++) {
        scanf("%d",&dp[i][1]);
    }
    while(scanf("%d%d",&l,&k),l||k) {
        father[l]=k;
    }
    root=k;
    while(father[root]) {
        root=father[root];
    }
    treedp(root);
    printf("%d\n",max(dp[root][0],dp[root][1]));

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章