PAT A1078. Hashing (25)

  1. Hashing (25)

時間限制
100 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be “H(key) = key % TSize” where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -

#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxm=10010;
int a[maxm]={0};
int n,m;

bool isprime(int m){
    if(m==1)return false;
    for(int i=2;i<=sqrt(m);i++){
        if(m%i==0)return false;
    }
    return true;
}

int find(int m){
    for(int i=m;;i++){
        if(isprime(i))return i;
    }
}

int main(){
    scanf("%d %d",&m,&n);
    m=find(m);
    for(int i=0;i<n;i++){
        int k;
        scanf("%d",&k);
        int j=0;
        int idx;
        while(j<m){
            idx=(k%m+j*j)%m;
            if(a[idx]==0){
                a[idx]=k;
                printf("%d",idx);
                break;
            }else{
                j++;
            }
        }
        if(j>=m)printf("-");
        if(i<n-1)printf(" ");
        else printf("\n");
    }
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章