1034. Head of a Gang (30)

  1. Head of a Gang (30)

時間限制
100 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threshold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:
8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 1:
2
AAA 3
GGG 3
Sample Input 2:
8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 2:
0

#include<cstdio>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn=2010;
int G[maxn][maxn];
map<string,int>strtoint;
string inttostr[maxn];
int N,T;
int cnt=0;
int weight[maxn]={0};
int gang=0;
int vis[maxn]={false};
int maxw,head,t;
string ans[maxn];
int anscnt[maxn]={0};

struct Answer{
    string ans;
    int anscnt;
}answer[maxn];

bool cmp(Answer a,Answer b){
    return a.ans<b.ans;
}
void dfs(int s){
    vis[s]=true;
    anscnt[gang]++;
    t+=weight[s];
    if(weight[s]>maxw){
        head=s;
        maxw=weight[s];
    }
    for(int i=0;i<cnt;i++){
        if(vis[i]==false&&G[s][i]!=0){
            dfs(i);
        }
    }
}

void DT(){
    for(int i=0;i<cnt;i++){
        if(vis[i]==false){
            maxw=0;
            head=-1;
            t=0;
            dfs(i);
            t/=2;
            ans[gang]=inttostr[head];
            if(t>T&&anscnt[gang]>2){
                //cout<<"head="<<ans[gang]<<endl;
                gang++;
            }else{
                anscnt[gang]=0;
            }
        }
    }
}
int main(){
    fill(G[0],G[0]+maxn*maxn,0);
    scanf("%d %d",&N,&T);
    for(int i=0;i<N;i++){
        string a,b;
        cin>>a;
        cin>>b;
        if(strtoint.find(a)==strtoint.end()){
            strtoint[a]=cnt;
            inttostr[cnt]=a;
            cnt++;
        }
        if(strtoint.find(b)==strtoint.end()){
            strtoint[b]=cnt;
            inttostr[cnt]=b;
            cnt++;
        }
        int x;
        scanf("%d",&x);
        G[strtoint[a]][strtoint[b]]+=x;
        G[strtoint[b]][strtoint[a]]+=x;
    }
    for(int i=0;i<cnt;i++){
        for(int j=0;j<cnt;j++){
            weight[i]+=G[i][j];
        }
    }
    //printf("cnt=%d AAA=%d CCC=%d HHH=%d\n",cnt,weight[0],weight[2],weight[7]);
    DT();
    for(int i=0;i<gang;i++){
        answer[i].ans=ans[i];
        answer[i].anscnt=anscnt[i];
    }
    sort(answer,answer+gang,cmp);
    printf("%d\n",gang);
    for(int i=0;i<gang;i++){
        cout<<answer[i].ans<<" "<<answer[i].anscnt<<endl;
    }
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章