PAT A1056. Mice and Rice (25)

  1. Mice and Rice (25)

時間限制
100 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,…NP-1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,…NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=1010;
struct Mice{
    int id;
    int w;
    int rank;
    int flag;
}mice[maxn];

int n,m;
queue<int>q;

bool cmp1(Mice a,Mice b){
    return a.rank>b.rank;
}
bool cmp2(Mice a,Mice b){
    return a.id<b.id;
}
int main(){
    scanf("%d %d",&n,&m);
    for(int i=0;i<n;i++){
        scanf("%d",&mice[i].w);
        mice[i].id=i;
        mice[i].rank=0;
        mice[i].flag=maxn;
    }
    for(int i=0;i<n;i++){
        int id;
        scanf("%d",&id);
        q.push(id);
        mice[i].rank++;
    }
    int cntnow;
    int idx;
    while(q.size()>1){
        cntnow=q.size();
        while(cntnow>0){
            int max=0,maxid=-1;
            for(int i=0;i<m&&cntnow>0;i++){
                idx=q.front();
                q.pop();
                if(mice[idx].w>max){
                    max=mice[idx].w;
                    maxid=idx;
                }
                cntnow--;
            }
            q.push(maxid);
            mice[maxid].rank++;
        }
    }
    sort(mice,mice+n,cmp1);
    mice[0].flag=1;
    for(int i=1;i<n;i++){
        if(mice[i].rank==mice[i-1].rank)mice[i].flag=mice[i-1].flag;
        else mice[i].flag=i+1;
    }
    sort(mice,mice+n,cmp2);
    for(int i=0;i<n;i++){
        printf("%d",mice[i].flag);
        if(i<n-1)printf(" ");
    }
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章