PAT A1039. Course List for Student (25)

  1. Course List for Student (25)

時間限制
200 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

第一種解法: map

#include<cstdio>
#include<iostream>
#include<map>
#include<set>
using namespace std;
map<string,set<int>>mp;
int n,k;

int main(){
    scanf("%d %d",&n,&k);
    for(int i=0;i<k;i++){
        int c,m;
        scanf("%d %d",&c,&m);
        for(int j=0;j<m;j++){
            string s;
            cin>>s;
            mp[s].insert(c);
        }
    }
    for(int i=0;i<n;i++){
        string s;
        cin>>s;
        cout<<s<<" "<<mp[s].size();
        for(set<int>::iterator it=mp[s].begin();it!=mp[s].end();it++){
            cout<<" "<<*it;
        }
        cout<<endl;
    }
    return 0;
}

這裏寫圖片描述

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int N=40010;
const int M=26*26*26*10+1;
vector<int>selectCourse[M];

int getID(char name[]){
    int id=0;
    for(int i=0;i<3;i++){
        id=id*26+name[i]-'A';
    }
    id=id*10+name[3]-'0';
    return id;
}

int main(){
    char name[5];
    int n,k;
    scanf("%d%d",&n,&k);
    for(int i=0;i<k;i++){
        int course,x;
        scanf("%d%d",&course,&x);
        for(int j=0;j<x;j++){
            scanf("%s",name);
            int id=getID(name);
            selectCourse[id].push_back(course);
        }
    }
    for(int i=0;i<n;i++){
        scanf("%s",name);
        int id=getID(name);
        sort(selectCourse[id].begin(),selectCourse[id].end());
        printf("%s %d",name,selectCourse[id].size());
        for(int j=0;j<selectCourse[id].size();j++){
            printf(" %d",selectCourse[id][j]);
        }
        printf("\n");
    }
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章