PAT A1031. Hello World for U (20)

  1. Hello World for U (20)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.
Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h !
e d
l l
lowor

#include<cstdio>

char s[10010];
int n1,n2;
void deal(char s[]){
    int i=0;
    while(s[i]!='\0'){
        i++;
    }
    int n=i;
    if(n%3==0){
        n1=n/3-1;
        n2=n-2*n1;
    }else{
        n1=n/3;
        n2=n-2*n1;
    }
    for(int i=0;i<n1;i++){
        printf("%c",s[i]);
        for(int j=2;j<n2;j++){
            printf(" ");
        }
        printf("%c\n",s[n-1-i]);
    }
    for(int i=n1;i<n1+n2;i++){
        printf("%c",s[i]);
    }
}
int main(){
    scanf("%s",s);
    deal(s);
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章