PAT A1029. Median (25)

  1. Median (25)

時間限制
1000 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=1000010;
ll a[maxn];
ll b[maxn];
int n1,n2;
int main(){
    scanf("%d",&n1);
    for(int i=0;i<n1;i++){
        scanf("%lld",a+i);
    }
    scanf("%d",&n2);
    for(int i=0;i<n2;i++){
        scanf("%lld",b+i);
    }
    int i=0,j=0;
    int cnt=0;
    while(i<n1&&j<n2){
        if(a[i]<b[j]){
            i++;
            cnt++;
            if(cnt==(n1+n2+1)/2){
                printf("%lld",a[i-1]);
                break;
            }
        }
        else{
            j++;
            cnt++;
            if(cnt==(n1+n2+1)/2){
                printf("%lld",b[j-1]);
                break;
            }
        }
    }
    if(cnt<(n1+n2+1)/2){
        while(i<n1){
            i++;
            cnt++;
            if(cnt==(n1+n2+1)/2){
                printf("%lld",a[i-1]);
                break;
            }
        }
        while(j<n2){
            j++;
            cnt++;
            if(cnt==(n1+n2+1)/2){
                printf("%lld",b[j-1]);
            }
        }
    }
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章