PAT A1037. Magic Coupon (25)

  1. Magic Coupon (25)

時間限制
100 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M)whereanegativevaluecorrespondstoabonusproduct.Youcanapplycoupon3(withNbeing4)toproduct1(withvalueM 7) to get M28back;coupon2toproduct2togetM 12 back; and coupon 4 to product 4 to get M3back.Ontheotherhand,ifyouapplycoupon3toproduct4,youwillhavetopayM 12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1000000;
typedef long long ll;
int a[maxn];
int b[maxn];
int main(){
    int n,m;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",a+i);
    }
    sort(a,a+n);
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        scanf("%d",b+i);
    }
    sort(b,b+m);
    int i=0;
    int j=0;
    ll ans=0;
    while(i<n&&j<n&&a[i]<0&&b[j]<0){
        ans+=a[i]*b[j];
        i++;
        j++;
    }
    i=n-1;
    j=m-1;
    while(i>=0&&j>=0&&a[i]>0&&b[j]>0){
        ans+=a[i]*b[j];
        i--;
        j--;
    }
    printf("%lld",ans);
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章