ACM——find your present (2)

find your present (2)

Time Limit: 1000/2000 MS (Java/Others) Memory Limit: 32768/1024 K (Java/Others)
Total Submission(s): 5339 Accepted Submission(s): 1569
 
Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 
Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 
Output
For each case, output an integer in a line, which is the card number of your present.
 
Sample Input
5
1 1 3 2 2
3
1 2 1
0
 
Sample Output
3
2

Hint
Hint
use scanf to avoid Time Limit Exceeded
 
Author
8600
 
Source
HDU 2007-Spring Programming Contest - Warm Up (1)
 
Recommend
8600
題意:
找到你的禮物
輸入禮物個數
輸入禮物的號碼
找出是奇數個的輸出
解決:
異或
整數的異或,先換成二進制然後進行按位異或。
異或滿足交換律
相同異或爲0,不同異或爲他本身。
注意初始化一個數爲0。
進行異或,得到的結果爲要求得的數。
正確代碼:
#include <stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int b,a=0;//注意a的初始化
        for(int i=0;i<n;i++)
        {
            scanf("%d",&b);
            a^=b;//異或,程序的主體部分
        }
        printf("%d\n",a);
    }
    return 0;
}
/****超內存,錯誤算法*****/
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define N 1000005
int a[N],c[N];
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            int b;
            scanf("%d",&b);
            a[b]++;
            c[i]=b;
        }
        for(int i=0;i<n;i++)
        {
            if(a[c[i]]%2==1)
            {
                printf("%d\n",c[i]);
                break;
            }
        }
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章