Oulipo

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 43547   Accepted: 17514

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source


題意:求第一個字符串在第二個字符串出現的次數
kmp算法
最好先將字符串的長度求出來,此題有毒 ,一直超時,看了討論區,說strlen()函數很耗時,然後改了,過了

代碼如下:
#include<iostream>
#include<stdio.h>
#include<cmath>
#include<string.h>
#include<string>

const int N=1000005;
using namespace std;
int next[N];
void get_next(int next[],char s[],int len)
{
    int i=0,j=-1;
    j=next[0]=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            i++,j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int kmp(char s[],char t[],int ls,int lt)
{
    int i=0,j=0;
    int ans=0;
    while(i<ls)
    {
        if(j==-1 || s[i]==t[j])
            i++,j++;
        else
            j=next[j];
        if(j>=lt){
            ans++;
            j=next[j];//可以添加,優化
        }
    }
    return ans;
}
int main()
{
    int n,ls,lt;
    char s[N],t[N];
    scanf("%d",&n);
    while(n--)
    {
        memset(next,0,sizeof(next));
        scanf("%s%s",s,t);
        ls=strlen(s);
        lt=strlen(t);
        get_next(next,s,ls);
        for(int i=0;i<ls;i++)
            cout<<next[i]<<" ";
        cout<<endl;
        printf("%d\n",kmp(t,s,lt,ls));
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章