PAT甲級真題 1065 A+B and C (64bit) (20分) C++實現(大數加法,預處理防溢出)

題目

Given three integers A, B and C in [−2​63, 263], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

思路

  • 若A、B異號或其中一個爲0,則可直接相加;
  • 若A、B > 0。若C <= 0,則直接true;若C > 0,轉換爲A > C - B
  • 若A、B < 0。若C >= 0,則直接false;若C < 0,轉換爲A > C - B

也可以利用溢出後變號的規律,最大值+1 = 最小值,相當於取值範圍是首尾相連的:

a:    9223372036854775807
a+1: -9223372036854775808

若兩個正數相加後溢出,則A + B 一定大於C。
若兩個負數相加後溢出,則A + B 一定小於C。
若不溢出,則直接驗證A + B > C即可。

代碼

#include <iostream>
using namespace std;

int main(){
    long long n;
    cin >> n;
    for (int i=0; i<n; i++){
        long long a, b, c;
        cin >> a >> b >> c;
        bool ret = false;
        if ((a^b)<0 || (a&b)==0){  //a、b異號,或有一個爲0
            if (a + b > c) {
                ret = true;
            }
        }
        else{  //a、b同號
            if (a>0 && b>0){
                if (c <= 0){
                    ret = true; 
                }
                else if (a > c - b){
                        ret = true; 
                }
            }
            else if(c<0 && a>c-b){
                ret = true;
            }
        }
        cout << "Case #" << i + 1;
        if (ret){
            cout << ": true" << endl;;
        }
        else{
            cout << ": false" << endl;;
        }
    }
    return 0;
}

利用溢出的方法:

#include<iostream>

using namespace std;

int main(){
    int n;
    cin >> n;
    for (int i=0; i<n; i++){
        long long a, b, c;
        bool ret = false;			
        cin >> a >> b >> c;
        long long sum = a + b;
        if(a>0 && b>0 && sum<=0) ret = true;
        else if(a<0 && b<0 && sum>=0) ret = false;
        else if(sum > c) ret = true;
        cout << "Case #" << i + 1;
        if (ret){
            cout << ": true" << endl;;
        }
        else{
            cout << ": false" << endl;;
        }
	}
	return 0;
} 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章