POJ1995 Raising Modulo Numbers - 快速冪運算

Raising Modulo Numbers

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13915   Accepted: 8242

Description

People are different. Some secretly read magazines full of interesting girls’ pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players’ experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression
(A1B1+A2B2+ … +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

 
 

題目大概意思:

給出 H(1H4.5×104)H(1≤H≤4.5×10^4) 對整數,第 ii 對整數是 (Ai,Bi)(A_i,B_i) ,計算 (i=1HAiBi)(\sum_{i=1}^{H}{A_i^{B_i}}) modmod M(1M4.5×104)M(1≤M≤4.5×10^4) .

 
 

分析:

運用倍增的思想,直接使用快速冪計算即可,時間複雜度爲 O(Hlog2B)O(H·\log_2{B}) .

 
 
下面貼代碼:

#include <cstdio>
#include <cmath>
using namespace std;


int mod_pow(int x, int p, int m);


int main()
{
	int Z, M, H, A, B;
	scanf("%d", &Z);

	while (Z--)
	{
		int ans = 0;
		scanf("%d%d", &M, &H);
		for (int i = 0; i < H; ++i)
		{
			scanf("%d%d", &A, &B);
			ans = (ans + mod_pow(A % M, B, M)) % M;
		}
		printf("%d\n", ans);
	}

	return 0;
}

int mod_pow(int x, int p, int m)
{
	int res = 1;
	while (p)
	{
		if (p & 1)
		{
			res = res * x % m;
		}
		x = x * x % m;
		p >>= 1;
	}
	return res;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章