POJ 2151 Check the difficulty of problems(概率DP)

傳送門

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:

1. All of the teams solve at least one problem.

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.


Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.


Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2 
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

題目大意:

T 個隊伍, M 個題目,現在給出第 i 個隊伍做出第 j 道題的概率pi,j ,求冠軍至少做出 N 道題且所有隊伍至少做出一道題的概率 p

解題思路:

首先我們將問題轉化一下:
設所有隊伍至少做出一道題的概率爲 p1
設所有隊伍做出題數都在區間 [1,N1] 中的概率爲 p2
那麼可以推出我們要求的 p=p1p2
考慮 DP,設 dp[i][j][k]: i  j  k  那麼有如下轉移方程成立:

dp[i][j][k]=pi,jdp[i][j1][k1]+(1pi,j)dp[i][j1][k]

dp初始化: dp[i][0][0]=1dp[i][j][0] 可以求出
設有 s[i][j]: i  j () ,那麼有
s[i][j]=k=0jdp[i][M][k]

那麼就有:
p1=i=1T(s[i][M]s[i][0])

p2=i=1T(s[i][N1]s[i][0])

至此,此題結束。

代碼:

#include <iostream>
#include <string.h>
#include <string>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <map>
using namespace std;
typedef long long LL;
const int MAXN = 1e3+5;
const double PI = acos(-1);
const double eps = 1e-8;
const LL MOD = 1e9+7;
double dp[MAXN][35][35], s[MAXN][35], p[MAXN][35];
int main(){
    //freopen("C:/Users/yaonie/Desktop/in.txt", "r", stdin);
    //freopen("C:/Users/yaonie/Desktop/out.txt", "w", stdout);
    int T, M, N;
    while(~scanf("%d%d%d",&M, &T, &N)){
        if(M==0 && T==0 && N==0) break;
        for(int i=1; i<=T; i++) for(int j=1; j<=M; j++) scanf("%lf",&p[i][j]);
        //初始化
        memset(dp, 0, sizeof(dp));
        for(int i=1; i<=T; i++){
            dp[i][0][0] = 1;
            for(int j=1; j<=M; j++) dp[i][j][0] += (1-p[i][j])*dp[i][j-1][0];
        }

        for(int i=1; i<=T; i++)
            for(int j=1; j<=M; j++)
                for(int k=1; k<=j; k++)
                    dp[i][j][k] = p[i][j]*dp[i][j-1][k-1]+(1-p[i][j])*dp[i][j-1][k];
        for(int i=1; i<=T; i++){
            for(int j=0; j<=M; j++){
                s[i][j] = 0;
                for(int k=0; k<=j; k++) s[i][j] += dp[i][M][k];
            }
        }
        double p1 = 1, p2 = 1;
        for(int i=1; i<=T; i++){
            p1 *= (s[i][M] - s[i][0]);
            p2 *= (s[i][N-1] - s[i][0]);
        }
        printf("%.3f\n",p1-p2);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章