HDU-1213 How Many Tables(並查集基礎)

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

題目大意:

      有人過生日要準備桌子,他希望認識的人坐在同一張桌子,讓我們求最少需要多少桌子

解題思路:

      很簡單的裸的並查集,對於給定的關係做Union操作,最後看有多少個集合就行

#include<iostream>

using namespace std;

const int maxN = 1010;

int parentArr[maxN];
//查找根節點
int getParent(int x) {
    //不是根節點
    while(parentArr[x] != x) {
        x = parentArr[x];
    }
    return x;
}

//兩個集合的合併
void Union(int x, int y) {
    int xParent = getParent(x);
    int yParent = getParent(y);
    //兩個集合不屬於同一個集合
    if(xParent != yParent) {
        //進行合併
        parentArr[yParent] = xParent;
    }
}

int main() {
    int t, n, m, x, y, res;
    cin >> t;
    while(t--) {
        cin >> n >> m;
        //初始化
        res = 0;
        for(int i = 1;i <= n;i++) {
            parentArr[i] = i;
        }
        for(int i = 1;i <=m;i++) {
            cin >> x >> y;
            //將兩個集合合併
            Union(x,y);
        }
        //查找有幾個不同的集合
        for(int i = 1;i <= n;i++) {
            if(parentArr[i] == i) {
                res++;
            }
        }
        cout << res << endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章