zoj3640(概率DP求期望)

地址:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4808

Help Me Escape

Time Limit: 2 Seconds      Memory Limit: 32768 KB

Background

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him. 
    And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him. 
    And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother's keeper? 
    And he said, What hast thou done? the voice of thy brother's blood crieth unto me from the ground. 
    And now art thou cursed from the earth, which hath opened her mouth to receive thy brother's blood from thy hand; 
    When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD's punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let's use the following function to describe their relationship:

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3

Sample Output

6.889

題意:幫助該隱跑路。一共有N條路,每條路都有危險值ci,該隱戰鬥力爲f。每天該隱任選一條路,如果其戰鬥力大於該路,那就花費ti天走出,否則花費一天增長ci戰鬥力。問逃走天數的期望。

思路:基本方法,就是有些小改動。

代碼:

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
//#include<algorithm>
using namespace std;
double p[10010];
int l[10010];
int main()
{
    int n,f;
    while(scanf("%d%d",&n,&f)>0)
    {
        memset(p,0,sizeof(p));
        int maxx=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&l[i]);
            maxx=max(maxx,l[i]);
        }
        maxx=max(maxx,f)+1;
        for(int i=maxx;i>=f;i--)
        {
            for(int j=1;j<=n;j++)
            {
                int k=(int)((1.0+sqrt(5.0))/2*l[j]*l[j]);
                if(l[j]<i) p[i]+=k*1.0/n;
                else p[i]+=(p[min(maxx,i+l[j])]+1)/n;  //如果超過了maxx那所有情況都一樣
            }
        }
        printf("%.3lf\n",p[f]);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章