HDU 3746 Cyclic Nacklace (KMP和循環節)

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~’z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
Sample Input
3
aaa
abca
abcde
Sample Output
0
2
5

題意:只能在頭和尾加字母,問最少加多少個可以使整個字符串變爲完整的循環

做法:可以用next數組先求出週期
即 int t=n-next[n]
然後判斷還差多少個字母成爲一個完整週期

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#define maxn 1000010
using namespace std;
int nex[maxn];
int ans[maxn];
int dp[maxn];
char s1[maxn];
char s2[maxn];
const int mod=10007;
void getNext(char* P, int* f)
{
    int m = strlen(P);
    f[0] = 0;
    f[1] = 0;
    for(int i = 1; i < m; i++)
    {
        int j = f[i];
        while(j && P[i] != P[j])
        {
            j = f[j];
        }
        f[i + 1]=P[i]==P[j]?j+1:0;
    }
}

int kmp(char* T, char*P, int*f)
{
    int n = strlen(T), m = strlen(P);
    int j = 0;
    int ans=0;
    for(int i = 0; i < n; i++)
    {
        while(j && P[j] != T[i])
        {
            j = f[j];
        }
        if(P[j] == T[i])
        {
            j++;
        }
        if(j == m)
        {
            ans++;
            j=0;
        }
    }
    return ans;
}
int main()
{

    int a;
    int n;
    int m;
    int ca=1;
    int  t;

    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d%s",&n,s1);
        getNext(s1,nex);
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            dp[i]=(dp[nex[i]]+1)%mod;
            ans=(ans+dp[i])%mod;
        }
        printf("%d\n",ans);

    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章