HDU 1358 Peroid(KMP和循環節)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

題意:看前I個字母是不是完整的循環字符串並輸出i和循環次數

做法:求出Next數組,對每個位置求週期,如果i|(i-next[i])就輸出就可以了

#include <string.h>
#include <iostream>
#include <cstdio>
#define maxn 1000010
int next[maxn];
void getNext(char* P, int* f)
{
    int m = strlen(P);
    f[0] = 0;
    f[1] = 0;
    for(int i = 1; i < m; i++)
    {
        int j = f[i];
        while(j && P[i] != P[j])
        {
            j = f[j];
        }
        f[i + 1]=P[i]==P[j]?j+1:0;
    }
}

int kmp(char* T, char*P, int*f)
{
    int n = strlen(T), m = strlen(P);
    getNext(P, f);
    int j = 0;
    for(int i = 0; i < n; i++)
    {
        while(j && P[j] != T[i])
        {
            j = f[j];
        }
        if(P[j] == T[i])
        {
            j++;
        }
        if(j == m)
        {
            return 1;//i-m+1
        }
    }
    return 0;
}
int main()
{
    char s1[maxn];
    char s2[maxn];
    int a;
    int n;
    int m;
    int ca=1;
    while(scanf("%d",&n)==1)
    {
        if(n==0)break;
        printf("Test case #%d\n",ca++);
        scanf("%s",s1);
        getNext(s1,next);
        int tmp=0;
        for(int i=1;i<=n;i++)
        {
            tmp=i-next[i];
            if(i%tmp==0&&i/tmp!=1)
            {
                printf("%d %d\n",i,i/tmp);
            }
        }
        printf("\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章