杭電 ACM 1018

Big Number


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17625    Accepted Submission(s): 7897




Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 


Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 


Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 


Sample Input
2
10
20
 


Sample Output
7
19
 


Source
Asia 2002, Dhaka (Bengal)
 


Recommend
JGShining

這個題一般,但是想過縮短時間就難了,下面是拷的別人的方法;可以看一下,後一個方法0ms,第一個900ms還多,

樸素公式爲:

    log10(n!)=log10(1*2*3…*n)=log10(1)+log10(2)+…+log10(n)

求位數:log10(n!)=log10(1*2*3…*n)=log10(1)+log10(2)+…+log10(n),對log10(n!)的值取整加1就是n!的位數。

《計算機程序設計藝術》中給出了另一個公式

    n! = sqrt(2*π*n) * ((n/e)^n) * (1 + 1/(12*n) + 1/(288*n*n) + O(1/n^3))

    π = acos(-1)

    e = exp(1)

兩邊對10取對數

忽略log10(1 + 1/(12*n) + 1/(288*n*n) + O(1/n^3)) ≈ log10(1) = 0

得到公式

    log10(n!) = log10(sqrt(2 * pi * n)) + n * log10(n / e)

代碼:

方法1:

#include<stdio.h>
#include<math.h>


int main(void)
{
int n;
int a;
int sum;
double multi;
int i, j;
scanf("%d", &n);
for(i = 0;i < n;i++)
{
scanf("%d", &a);
multi = 0.0;
for(j = 1;j <= a;j++)
{
multi += log10((double)j);
}
sum = (int)multi;
printf("%d\n", sum + 1);
}
return 0;
}

方法2:

#include<stdio.h>
#include<math.h>


int main(void)
{
int n, a;
int i, sum;
double pi, e;
pi = acos(-1.0);
e = exp(1.0);
scanf("%d", &n);
for(i = 0;i < n;i++)
{
sum = 0;
scanf("%d", &a);
sum = (int)(log10(sqrtl(2*pi*a))+a*log10(a/e)+1);;
if(a == 1)
sum = 1;
printf("%d\n", sum);
}
return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章