UVA 699 The Falling Leaves(二叉樹)

Question:
Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the
trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened
to binary trees, how large would the piles of leaves become?
We assume each node in a binary tree ”drops” a number of leaves equal to the integer value stored
in that node. We also assume that these leaves drop vertically to the ground (thankfully, there’s no
wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a
manner that the left and right children of a node are exactly one unit to the left and one unit to the
right, respectively, of their parent. Consider the following tree on the right:
The nodes containing 5 and 6 have the same horizontal position
(with different vertical positions, of course). The node
containing 7 is one unit to the left of those containing 5 and
6, and the node containing 3 is one unit to their right. When
the ”leaves” drop from these nodes, three piles are created:
the leftmost one contains 7 leaves (from the leftmost node),
the next contains 11 (from the nodes containing 5 and 6), and
the rightmost pile contains 3. (While it is true that only leaf
nodes in a tree would logically have leaves, we ignore that in
this problem.)
Input
The input contains multiple test cases, each describing a single tree. A tree is specified by giving the
value in the root node, followed by the description of the left subtree, and then the description of the
right subtree. If a subtree is empty, the value ‘-1’ is supplied. Thus the tree shown above is specified
as ‘5 7 -1 6 -1 -1 3 -1 -1’. Each actual tree node contains a positive, non-zero value. The last test
case is followed by a single ‘-1’ (which would otherwise represent an empty tree).
Output
For each test case, display the case number (they are numbered sequentially, starting with 1) on a line
by itself. On the next line display the number of “leaves” in each pile, from left to right, with a single
space separating each value. This display must start in column 1, and will not exceed the width of an
80-character line. Follow the output for each case by a blank line. This format is illustrated in the
examples below.
Sample Input
5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1
-1
Sample Output
Case 1:
7 11 3
Case 2:
9 7 21 15
題目大意:給你一棵二叉樹(先序遍歷),輸入-1表示無此節點。一個節點的左節點在其左邊一個單位,右節點在其右邊一個單位,判斷這棵樹豎直方向上之和最大爲多少(例如一個節點跟它左節點的右節點在同一豎直方向上,跟它右節點的左節點在同一個豎直方向上)
解題思路:用一個數組表示sum[p]表示在豎直座標p上的和,在建樹的同時計算sum[p],最後再遍歷豎直各個座標上的和,取出最大
(http://vjudge.net/contest/132880#problem/E)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
int sum[maxn];
void build(int p)  //邊建樹邊輸入,並同時計算sum[p];
{
    int v;
    cin>>v;
    if(v==-1)
        return ;
    sum[p]+=v;
    build(p-1);
    build(p+1);
}
bool init()
{
    int v;
    cin>>v;
    if(v==-1)
        return false;
    memset(sum,0,sizeof(sum));
    int pos=maxn/2;    //使頭結點位於數組中間,方便計算
    sum[pos]=v;
    build(pos-1);
    build(pos+1);
}
int ncase;
int main()
{
    while (init())
    {
        int p=0;
        while (sum[p]==0)
            p++;
        cout<<"Case "<<++ncase<<":\n"<<sum[p++];
        while (sum[p]!=0)
            cout<<" "<<sum[p++];
        cout<<endl<<endl;
    }
    return 0;
}

體會:這是一道二叉樹的簡單題,只要想清楚了,迎刃而解。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章