hdu 1599 Common Subsequence(DP)

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm> another sequence Z = < z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c> is a subsequence of X = < a, b, c, f, b, c> with index sequence < 1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab
programming contest
abcd mnp

Sample Output
4
2
0

#include<iostream>
#include<cstdio>
#include<string.h>
#include<stdlib.h>
#include<math.h>
using namespace std;
const int maxn=1000+5;
char a[maxn],b[maxn];
int dp[maxn][maxn];

int main(){
    while(scanf("%s",a+1)!=EOF){
        scanf("%s",b+1);

        memset(dp,0,sizeof(dp) );

    //  cout<<"strlena+1="<<strlen(a+1)<<endl;
    //  cout<<"strlenb+1="<<strlen(b+1)<<endl;
        for(int i=1;i<=strlen(a+1);i++)
            for(int j=1;j<=strlen(b+1);j++){
                if(a[i]==b[j]){ 
                    dp[i][j]=dp[i-1][j-1]+1; 
                } 
                else{ 
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                } 
            }
        cout<<dp[strlen(a+1)][strlen(b+1)]<<endl;
    }
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章