HDU-2391 Filthy Rich(簡單DP)

They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so? 

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner. 

Input

The input starts with a line containing a single integer, the number of test cases. 
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative. 
The maximum amount of gold will always fit in an int.

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line. 

Sample Input

1
3 4
1 10 8 8
0 0 1 8
0 27 0 4

Sample Output

Scenario #1:
42

題目意思:

只能往下或往右或往右下角,問從左上角走到右下角,路徑上的數字之和最大 

解題思路:

由於每一步只能往左或右或右下走,那麼每一種種狀態都可以由上一個狀態(arr[i-1][j]或arr[i][j-1]或arr[i-1][j-1])的值加上當前點的權值即可即可推出狀態轉移方程爲arr[i][j] += max(arr[i-1][j],max(arr[i][j-1],arr[i-1][j-1]))

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int t,n,m,arr[1001][1001];

int Max(int a,int b) {
    return a > b ? a : b;
}

int main() {
    scanf("%d",&t);
    for(int caseNum = 1;caseNum <= t;caseNum++){
        printf("Scenario #%d:\n",caseNum);
        memset(arr,0,sizeof(arr));
        scanf("%d%d",&n,&m);
        for(int i = 1;i <= n;i++) {
            for(int j = 1;j <= m;j++) {
                scanf("%d",&arr[i][j]);
            }
        }
        for(int i = 1;i <= n;i++) {
            for(int j = 1;j <= m;j++) {
                arr[i][j] += Max(arr[i-1][j],Max(arr[i][j-1],arr[i-1][j-1]));
            }
        }
        printf("%d\n\n",arr[n][m]);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章