PAT 甲级 A1039

1039 Course List for Student (25分)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入格式

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i
​​ (≤200) are given in a line. Then in the next line, N​i, student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出格式

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

总结

  看一眼题目要求查询得到这么复杂的结果,就知道…肯定要用散列。刚开始我是用的C++11的unordered_map,后来发现输出结果不对…看来没掌握到精髓,于是就自己写了个散列函数。散列函数的实现也很简单,每移一个位,就乘一个位不同情况的个数(类似于计算二进制)。再配合一个变长数组vector,就可以计算出每个学生和他的对应选课。思路和实现都在代码下面了。

AC代码

#include <iostream>
#include<algorithm>
#include<vector>
using namespace std;
vector<int> stu[26 * 26 * 26 * 10 + 1];
int strHash(char stu[]) {  //散列,三个大写字母的和一个数字的组合最多为26*26*26*10 < 270000
	int id = 0;
	for (int i = 0; i < 3; i++) id = id * 26 + (stu[i] - 'A');
	id = id * 10 + stu[3] - '0';
	return id;
}
int main() {
	int n, k, cousreId, stuNums;
	char temp[5];
	scanf("%d %d", &n, &k);
	for (int i = 0; i < k; i++) {
		scanf("%d %d", &cousreId, &stuNums);
		for (int j = 0; j < stuNums; j++) {
			scanf("%s", temp);
			int index = strHash(temp);
			stu[index].push_back(cousreId);
		}
	}
	while (~scanf("%s", temp)) {
		int index = strHash(temp);
		printf("%s %d", temp, stu[index].size());
		if (stu[index].size()) {
			sort(stu[index].begin(), stu[index].end());
			for (auto i = stu[index].begin(); i != stu[index].end(); i++)
				printf(" %d", *i);
		}
		printf("\n");
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章