PAT 甲級 A1056

1056 Mice and Rice (25分)

題目描述

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P programmers. Then every N​G programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

輸入格式

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​Pand NG(≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG
​​mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N​P distinct non-negative numbers W​i(i=0,⋯,N​P−1) where each W​i is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P−1(assume that the programmers are numbered from 0 to N​P−1). All the numbers in a line are separated by a space.

輸出格式

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

總結

這題想了半天想不出來,一直想的是用樹來做但不知道代碼怎麼寫QWQ。後來看了下書才發現排名和組號居然有着神奇的+1關係(給跪了)。發現了這個規律代碼就好寫多了,直接用隊列來模擬序號對應老鼠的排名。稍微注意一下題目給的初始序列,初始老鼠們的重量序列應該是19 25 57 22 10 3 56 18 37 0 46,這個序列的排名結果竟然和25 18 0 46 37 3 19 22 57 56 10這個一樣…不得不服。最後還要記得給第一名的老鼠排名。

AC代碼

#include <iostream>
#include<math.h>
#include<queue>
using namespace std;
struct Programmer {
	int weight, rank;
}p[1005];
int main()
{
	int total, ng, seq, groupNums, now;
	queue<int> que;
	scanf("%d%d", &total, &ng);
	for (int i = 0; i < total; i++) {
		scanf("%d", &p[i].weight);
	}
	for (int i = 0; i < total; i++) { //隊列裏爲需要比較的老鼠序號
		scanf("%d", &seq);
		que.push(seq);
	}
    now = total;
	while (now > 1) { //這輪老鼠數
		groupNums = ceil((double)now / ng); //組數
		for (int i = 0; i < groupNums; i++) {
			int id = que.front();
			for (int j = 0; j < ng && i*ng + j < now; j++) {//每組找最大
				int seq = que.front();
				que.pop();
				if (p[seq].weight > p[id].weight) {//找出最大的id
					id = seq;
				}
				p[seq].rank = groupNums + 1;
			}
			que.push(id);
		}
		now = groupNums;
	}
	p[que.front()].rank = 1;
	for (int i = 0; i < total - 1; i++) { 
		printf("%d ", p[i].rank);
	}
	printf("%d\n", p[total - 1].rank);
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章