PAT 甲級 A1051

1051 Pop Sequence (25分)

題目描述

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4

輸入格式

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

輸出格式

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

總結

  1. 題目大概意思是,給出棧最大容量和需要入棧的數字,讓你判斷給定的出棧序列是否合法。
  2. 首先設置一個數組,來存儲一行的出棧序列。設當前待入棧的元素爲num,棧頂元素位data[i],用一個while循環直到num == data[i]時跳出,然後再判斷這個棧是否超出了最大容量m,循環執行。

AC代碼

#include <iostream>
#include<stack>
using namespace std;
int main()
{
	int m, n, k, num, data[1005];
	stack<int> s;
	scanf("%d%d%d", &m, &n, &k);
	getchar();
	while (k--) {
		bool flag = true;
		while (!s.empty()) s.pop();
		num = 1;  //當前入棧元素
		for (int i = 0; i < n; i++) {
			scanf("%d", &data[i]);
		}
		for (int i = 0; i < n; i++) {
			if (s.empty() && num <= n) {
				s.push(num++);  //入棧元素序號+1
			}
			while (s.top() != data[i] && num <= n) {
				s.push(num++);
			}
			if (s.size() > m || s.top() != data[i]) {  //出棧序列不合法也會導致 s.top() != data[i] 
				flag = false;
				break;
			}
			s.pop();
		}
		if (flag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章