HDU 3367

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2663    Accepted Submission(s): 1047


Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

Sample Input
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
 

Sample Output
3 5
 
題意:求一棵最大生成樹,這個最大生成樹可以有一個環。
思路:kruskal加並查集判環。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10240;
int f[maxn];
int vis[maxn];
struct node
{
    int s,e,v;
    bool operator <(const node &a)const
    {
        return v > a.v;
    }
}e[maxn*10];
int Find(int x)
{
    return x == f[x]?x:f[x] =  Find(f[x]);
}
bool Union(int x,int y)
{
    int xx = Find(x);
    int yy = Find(y);
    if(xx == yy)
    {
        if(!vis[xx])
        {
            vis[xx] = 1;
            return true;
        }
        return false;
    }
    else
    {
        if(vis[xx]+vis[yy]<=1)
        {
            f[xx] = yy;
            vis[yy] += vis[xx];
            return true;
        }
        return false;
    }
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&(n+m))
    {
        memset(vis,0,sizeof(vis));
        int ans = 0;
        for(int i = 0;i < n;i++)
            f[i] = i;
        for(int i = 0; i < m;i++)
        {
            scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].v);
        }
        sort(e,e+m);
        for(int i = 0;i < m;i++)
        {
            int u = e[i].s,v = e[i].e;
            if(Union(u,v))
                ans+=e[i].v;
        }
        printf("%d\n",ans);
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章