hdu 3368

Problem Description
Reversi, also called Othello, is a two-sided game.
Each of the two sides corresponds to one player; they are referred to here as light and dark after the sides of Othello pieces, but "heads" and "tails" would identify them equally as well, so long as each marker has sufficiently distinctive sides.
Originally, Reversi did not have a defined starting position. Later it adopted Othello's rules, which state that the game begins with four markers placed in a square in the middle of the grid, two facing light-up, two pieces with the dark side up. The dark player makes the first move.


Dark must place a piece with the dark side up on the board, in such a position that there exists at least one straight (horizontal, vertical, or diagonal) occupied line between the new piece and another dark piece, with one or more contiguous light pieces between them. In the below situation, dark has the following options indicated by transparent pieces:


After placing the piece, dark turns over (flips, captures) all light pieces lying on a straight line between the new piece and any anchoring dark pieces. All reversed pieces now show the dark side, and dark can use them in later moves—unless light has reversed them back in the meantime. In other words, a valid move is one where at least one piece is reversed.
If dark decided to put a piece in the topmost location (all choices are strategically equivalent at this time), one piece gets turned over, so that the board appears thus:


Now light plays. This player operates under the same rules, with the roles reversed: light lays down a light piece, causing a dark piece to flip. Possibilities at this time appear thus (indicated by transparent pieces):


Light takes the bottom left option and reverses one piece:


Players take alternate turns. If one player cannot make a valid move, play passes back to the other player. When neither player can move, the game ends. This occurs when the grid has filled up, or when one player has no more pieces on the board, or when neither player can legally place a piece in any of the remaining squares. The player with the most pieces on the board at the end of the game wins.
Now after several rounds, it’s dark’s turn. Can you figure out the largest number of light pieces he can turn over?
 

Input
The first line contains one integer T representing the number of test cases.
For each test case, there’re 8 lines. Each line contains 8 characters (D represents dark, L represents light, * represents nothing here).
Every two adjacent cases are separated by a blank line.
 

Output
For each test case, in one line print the case number and the largest number of light pieces the dark player can turn over. If he can’t put one piece in any position, then print 0.
Please follow the format of the sample output.
 

Sample Input
3 ******** ******** ******** ***LD*** ***DL*** ******** ******** ******** ******** ******** **DLL*** **DLLL** **DLD*** ******** ******** ******** ******** ******** *D****** *DLLD*** ***LL*** **D*D*** ******** ********
 

Sample Output
Case 1: 1 Case 2: 3 Case 3: 0
題意:黑白棋走了若干步,然後到黑棋走的時候,問最多能翻多少個白棋。

思路:dfs從“*”出發,朝8個方向找LLL……D這樣的段,求和,取最大值。讀錯了題這就很尷尬了……

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
char f[10][10];
int dx[8] = {-1,1,0,0,-1,-1,1,1};
int dy[8] = {0,0,-1,1,-1,1,-1,1};
int maxx,sum;
void dfs(int x,int y,int t,int num)
{
    if(8<=x||y>=8||x<0||y<0)return ;
    if(f[x][y] == 'L')
    {
        dfs(x+dx[t],y+dy[t],t,num+1);
    }
    else if(f[x][y] == '*')
        return ;
    else
        sum+=num;
}
int main()
{
    int t,kase = 1;
    scanf("%d",&t);
    while(t--)
    {
        for(int i = 0;i < 8;i++)
            scanf("%s",f[i]);
        maxx = 0;
        for(int i = 0;i < 8;i++)
        {
            for(int j = 0;j < 8;j++)
            {
                if(f[i][j]!='*')continue;
                sum = 0;
                for(int k = 0;k < 8;k++)
                {
                    dfs(i+dx[k],j+dy[k],k,0);
                }
                maxx = max(maxx,sum);
            }
        }
        printf("Case %d: %d\n",kase++,maxx);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章