POJ 3259 Wormholes 圖論 貝爾曼-福特算法(Bellman-Ford)

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 25757   Accepted: 9254

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

這道題是穿越題,穿越。。。題目意思是有個閒的無聊的農夫John(從題目中看農夫不是一般的閒),在自己農場裏建了一個圖,並且搞了一些正常的路和一些蟲洞(就是科幻電影裏面經常時光倒流什麼什麼的路徑),並且正常的路是雙向路,蟲洞是單向的,問農夫從任意一個頂點出發,是否可以當回到此頂點的時候發生時光倒流,即時間小於出發的時間,此題看來還是運用Bellman-Ford算法中負權環的定義,如果圖中出現一條負權環的話,則可以說明存在時光倒流的可能,輸出YES,不存在負權環的時候,輸出NO,這樣題目就被愉快的AC了。。。

下面是AC代碼:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
struct Edge{
    int u, v;    
    int time;
	int flag;
}edge[5500];
int dist[600],n,m,w;
void relax(int u, int v, int time)
{
    if(dist[v] > dist[u] + time)
        dist[v] = dist[u] + time;
}
bool Bellman_Ford()
{
	int i;
	for(i=1;i<=n;i++)
		dist[i]=100000;
    for(i=1; i<=n-1; ++i)
        for(int j=1; j<=2*m+w; ++j)
            relax(edge[j].u, edge[j].v, edge[j].time);
    bool flag = 1;
        for(i=1; i<=2*m+w; ++i)
        if(dist[edge[i].v] > dist[edge[i].u] + edge[i].time )
        {
            flag = 0;
            break;
        }
    return flag;
}
int main()
{
	int i,t;
	scanf("%d",&t);
	while(t--)
	{
		memset(edge,0,sizeof(edge));
		scanf("%d%d%d",&n,&m,&w);
		for(i=1;i<=2*m;i+=2)
		{
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].time);
			edge[i+1].u=edge[i].v;
			edge[i+1].v=edge[i].u;
			edge[i+1].time=edge[i].time;
		}
		for(i;i<=2*m+w;i++)
		{
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].time);
			edge[i].time=-edge[i].time;
		}
		if(Bellman_Ford()==0)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章