POJ 1251 Jungle Roads - C語言 - Kruskal算法

Description

Jungle Roads

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

題解

題目的核心是:構造一棵最小生成樹。我採用的是 Kruskal 算法來解決此問題。

定義如下結構體保存路線信息:

struct node {
	char u, v;// 起點和終點
	int cost;// 花費
} roads[MAX_ROADS];// 路線
int roads_num;

Kruskal 算法構造最小生成樹的步驟如下:

  1. 初始化每個頂點爲一棵樹,根結點是自己
  2. 遍歷所有邊,找到花費最小的邊
    1. 如果這條邊的兩點屬於同一棵樹,那麼不用處理
    2. 如果這條邊的兩點屬於不同的樹,那麼將這兩棵樹合併(修改一個根結點的父結點爲另一個根結點)
  3. 重複第2步,直到所有頂點都屬於同一棵樹爲止

對於此題而言,只需要在2.2中將花費加起來,最後的和就是最小花費。


C代碼

/*********************************************************************
File: 1251 -- Jungle Roads
Result: Accepted
Memory: 340K
Time: 0MS
Language: GCC
Code Length: 2028B
Version: 1.3
From: https://www.cnblogs.com/wowpH/p/11908562.html
Author: wowpH
Date: 2019-11-22 15:18:59
*********************************************************************/
#include <stdio.h>
#include <stdlib.h>

#define MAX_N 26
#define MAX_ROADS 75

struct node {
	char u, v;// 起點和終點
	int cost;// 花費
} roads[MAX_ROADS];// 路線
int roads_num;

int father[MAX_N];// 父結點,用於並查集

void input_roads(int n);
int compare(const void* a, const void* b);
int kruskal();
void init();
int merge(int u, int v);
int find(int x);

int main(void) {
	int n;// 村莊個數
	while (scanf("%d", &n) != EOF && n > 0) {
		input_roads(n);// 輸入路線
		// 按照花費升序排序
		qsort(roads, roads_num, sizeof(struct node), compare);
		printf("%d\n", kruskal());// 輸出最小花費
	}
	return 0;
}

void input_roads(int n) {
	roads_num = 0;// 路線個數重置爲0
	char start, end;
	int number, cost;
	for (int i = 1; i < n; ++i) {
		scanf(" %c %d", &start, &number);// 輸入起點和終點個數
		for (int j = 0; j < number; ++j) {
			scanf(" %c %d", &end, &cost);// 輸入終點和花費
			roads[roads_num].u = start;
			roads[roads_num].v = end;
			roads[roads_num].cost = cost;
			++roads_num;
		}
	}
}

int compare(const void* a, const void* b) {
	return (*(struct node*)a).cost - (*(struct node*)b).cost;// 升序
}

int kruskal() {// 克魯斯卡爾算法,並查集算法實現
	init();// 初始化
	int min_cost = 0;// 最小花費
	int u, v;// 起點,終點
	for (int i = 0; i < roads_num; ++i) {
		u = roads[i].u - 'A';
		v = roads[i].v - 'A';
		if (merge(u, v) == 0) {// 合併成功,此路線屬於最小生成樹
			min_cost += roads[i].cost;
		}
	}
	return min_cost;
}

void init() {// 並查集的初始化
	for (int i = 0; i < MAX_N; ++i) {// 初始化父結點爲自己
		father[i] = i;
	}
}

int merge(int u, int v) {// 並查集的合併
	u = find(u);
	v = find(v);
	if (u != v) {// 不屬於同一個集合,可以合併
		father[v] = u;// 合併
		return 0;// 成功
	}
	return -1;
}

int find(int x) {// 並查集的查找父結點
	if (father[x] != x) {
		father[x] = find(father[x]);// 壓縮路徑
	}
	return father[x];
}

中文版:
我覺得這題就是考英文的。

有 n 個村莊,之間有一些道路,爲了維護道路需要花費一些錢,現在打算放棄部分道路,只維護 n-1 條道路,問最小的花費是多少?

這不就是最小生成樹的典型題目嗎?用 Prim 算法或者 Kruskal 算法即可。

限制條件:

  • 1 < n < 27
  • 1 <= 道路條數 <= 100

題目鏈接:http://poj.org/problem?id=1251
參考:Kruskal算法
原文鏈接:https://www.cnblogs.com/wowpH/p/11908562.html


wowpH - cnblogs
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章