08-1. Talent and Virtue

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(聖人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (<=105), the total number of people to be ranked; L (>=60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade
where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (<=N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:
14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60
Sample Output:
12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

提示:英文太多,表示看不懂,所以請看中文版,http://www.patest.cn/contests/pat-b-practise/1015


分析:建立四個容器vector存放4個類別的容器,分別是:聖人、君子、愚人、小人。 然後直接用sort函數進行排序,自己寫一個比較函數,下面代碼有。

特比需要說明一下的是,這道題一開始我用c++做完是拿去測試,測試點3,4就是會測試超時,改了很久還是不行,最後通過相關的資料才明白是c++的輸入輸出的問題,

使用cout和cin會使3,4超時,但是改成c語言的printf和scanf就就解決了,所以在這裏需要注意一下


源碼:

#include<iostream>
#include<algorithm>
#include<vector>
#include <cstdio>

using namespace std;
struct student {
	int ID_Number;
	int Virtue_Grade;
	int Talent_Grade;
	student(int id, int vg, int tg) :ID_Number(id), Virtue_Grade(vg), Talent_Grade(tg) {}
	void output(){
		printf("%d %d %d\n", ID_Number, Virtue_Grade, Talent_Grade);
	}
};
//比較函數
bool compare(const student &m1, const student &m2){
	if ((m1.Talent_Grade + m1.Virtue_Grade) != (m2.Talent_Grade + m2.Virtue_Grade))
		return (m1.Talent_Grade + m1.Virtue_Grade) > (m2.Talent_Grade + m2.Virtue_Grade);
	else{
		if (m1.Virtue_Grade != m2.Virtue_Grade)
			return m1.Virtue_Grade > m2.Virtue_Grade;
		else
			return m1.ID_Number < m2.ID_Number;
	}
}

int main()
{
	int N, L, H;
	scanf("%d %d %d", &N, &L, &H);
	vector<student> s1, s2, s3, s4;
	int id,vg,tg;
	int cnt = 0;
	//讀入信息並刪掉成績不符合要求的考生
	for (int i = 0; i < N; i++){
		scanf("%d %d %d", &id, &vg, &tg);
		if (tg < L || vg < L)			//不合格者
			continue;
		//才德全盡 的考生放到s1
		if (tg >= H && vg >= H){		
			s1.push_back(student(id,vg,tg));
		}
		//德勝才  的考生放到s2
		else if (vg >= H && tg <= H){		
			s2.push_back(student(id, vg, tg));
		}
		//才德兼亡 但尚有 德勝才 的考生放到s3
		else if (vg < H && tg< H && vg >= tg){
			s3.push_back(student(id, vg, tg));
		}
		//剩下的合格考生放道s4
		else
			s4.push_back(student(id, vg, tg));
		cnt++;
	}	
	cout << cnt << endl;;
	//穩定排序
	sort(s1.begin(), s1.end(), compare);
	sort(s2.begin(), s2.end(), compare);
	sort(s3.begin(), s3.end(), compare);
	sort(s4.begin(), s4.end(), compare);

	//輸出
	for (int i = 0; i < s1.size(); i++){
		s1[i].output();
	}
	for (int i = 0; i < s2.size(); i++){
		s2[i].output();
	}
	for (int i = 0; i < s3.size(); i++){
		s3[i].output();
	}
	for (int i = 0; i < s4.size(); i++){
		s4[i].output();
	}

	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章