【POJ - 2230 Watchcow】 歐拉回路

G - Watchcow


Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.
Input
* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
Output
* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
Sample Input
4 5
1 2
1 4
2 3
2 4
3 4
Sample Output
1
2
3
4
2
1
4
3
2
4
1
Hint
OUTPUT DETAILS:

Bessie starts at 1 (barn), goes to 2, then 3, etc...



題意:從一個點出發,經過每一條邊兩次並回到最初的點,輸出行走路徑。


分析:輸出經過歐拉回路的點,其實就是用深搜來回溯。


代碼如下:

#include <set>
#include <map>
#include <queue>
#include <cmath>
#include <vector>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define mod 835672545
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
const int MX = 5e4 + 5;
int n, m;
struct node{
    int key, ok;
    node(int x, int y):key(x), ok(y){};
};
vector<node> e[MX];
void dfs(int u){
    int len = e[u].size();
    for(int i = 0; i < len; i++){
        if(e[u][i].ok){
            e[u][i].ok = 0;
            dfs(e[u][i].key);
        }
    }
    printf("%d\n", u);
}
int main(){
    scanf("%d%d", &n, &m);
    for(int i = 0; i < m; i++){
        int u, v;
        scanf("%d%d", &u, &v);
        e[u].push_back(node(v, 1));
        e[v].push_back(node(u, 1));
    }
    dfs(1);
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章