PAT甲級A1013. Battle Over Cities (25)

題目描述

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

題目解析

使用深度遍歷DFS,檢查在缺少一個節點之後,圖被分成了cnt個連通域,則需要修建cnt-1條通道將所有點連通。

代碼

#include<iostream>
#include<vector>
using namespace std;

int N, M, K;

void DFS(int n,vector<bool>&citis, vector<vector<bool> >&hways)
{
    if (citis[n] != 0)
        return;
    citis[n] = 1;
    for (int p = 1; p < N + 1; ++p)
    {
        if (hways[n][p] == 1)
            DFS(p, citis, hways);
    }
    return;
}

int main()
{
    cin >> N >> M >> K;
    vector<int> lost(K);
    vector<vector<bool> >highways(N+1, vector<bool>(N+1, 0));
    for (int i = 0; i < M; ++i)
    {
        int a, b;
        cin >> a >> b;
        highways[a][b] = 1;
        highways[b][a] = 1;
    }
    for (int i = 0; i < K; ++i)
    {
        int a;
        cin >> a;
        lost[i] = a;
    }
    for (int i = 0; i < K; ++i)
    {
        vector<vector<bool> >h_ways_lost = highways;
        for (int p = 1; p < N + 1; ++p)
        {
            h_ways_lost[lost[i]][p] = 0;
            h_ways_lost[p][lost[i]] = 0;
        }
        vector<bool> citis(N + 1, 0);
        citis[lost[i]] = 1;
        int cnt = 0;
        for (int i = 1; i < N + 1; ++i)
        {
            if (citis[i] == 0)
            {
                ++cnt;
                DFS(i, citis, h_ways_lost);
            }
        }
        cout << cnt-1 << endl;
    }
    system("pause");
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章