The Suspects POJ - 1611(並查集)

題目鏈接
Vjudje
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

題意:
有很多組學生,在同一個組的學生經常會接觸,也會有新的同學的加入。但是SARS是很容易傳染的,只要在改組有一位同學感染SARS,那麼該組的所有同學都被認爲得了SARS。現在的任務是計算出有多少位學生感染SARS了。假定編號爲0的同學是得了SARS的。
思路:容易想到並查集中的集合與點,有許多點集。同一點集的點之間有邊,一個點可以在幾個點集中,若一個點集中有一個點屬於另一個點集,兩個點集便合併爲同一個點集。
代碼:

#include<stdio.h>
#include<string.h>
const int N=30005;
int f[N];
int p[N];
int n,m;
int find(int x)
{
	/*while(x!=f[x])
	x=f[x];
	return x;*/
    if(x==f[x])
    {
    	return x;
	}
	else
	{
		return f[x]=find(f[x]);
	}
}
int merge(int x,int y)
{
	int fy,fx;
	fy=find(y);
	fx=find(x);
	if(fy!=fx)
	{
		f[fy]=fx;
	}
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    	if(n==0&&m==0)
    	{
    		break;
		}
		int sum=0;
		for(int i=0;i<n;i++)
		{
			f[i]=i;
		}
		for(int i=0;i<m;i++)
		{
			int k;
			scanf("%d",&k);
			scanf("%d",&p[0]);
			for(int j=1;j<k;j++)
			{
				scanf("%d",&p[j]);
				merge(p[0],p[j]);
			}
		}
		for(int i=0;i<n;i++)
		{
			if(find(i)==f[0])
			{
				sum++;
			}
		}
		printf("%d\n",sum);
	}
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章