Is It A Tree?—— POJ - 1308

原題連接
vjudge
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

在這裏插入圖片描述
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
題目大意:

給出多組邊,讓你判斷這是不是一棵樹。邊的信息以( 始點, 末點)的形式給出以(0,0)結束.,數據以(-1,-1)輸入結束;
樹的定義:樹是指任意兩個結點之間有且僅有一條路徑的無向圖。或者說,只要是沒有迴路的連通無向圖就是樹。

#include<stdio.h>
#include<string.h>
#define N 100005
int p[N]={0};
int find(int x)
{
    while(x!=p[x])
    {
        x=p[x];
    }
    return x;
}
int merge(int x,int y)
{
    int fx,fy;
    fx=find(x);
    fy=find(y);
    if(fx!=fy)
    {
        p[fy]=fx;
    }
}
int main()
{
    int a,b,i,flag,sum;
    while(1)
    {
        flag=0;
        while(scanf("%d %d",&a,&b)&&a!=0&&b!=0)
        {
            if(a==-1||b==-1)
                return 0;
            if(p[a]==0) p[a]=a;
            if(p[b]==0) p[b]=b;
            if(find(a)==find(b)) flag=1;
            if(flag!=1)
                merge(a,b);
        }
        sum=0;
        for(i=1;i<=N;i++)
        {
            if(p[i]==i) sum++;
            p[i]=0;
        }
        if(sum>1||flag==1)
            printf("No\n");
        else
            printf("Yes\n");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章