杭電OJ_1003_A + B Problem II

A + B Problem II

Limit

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


題目解析

這題是建立在第一題的基礎上的擴展。增加了大數相加,增加了按固定格式輸出結果。AC 代碼如下。

代碼

#include <iostream>
#include <string.h>
using namespace std;

void add ( char a[], char b[] )
{
    char sum[1010] = {' '};
    int flg = 0;
    int temp = 0;
    int len_a = strlen ( a );
    int len_b = strlen ( b );
    int i = len_a;
    int j = len_b;
    for ( ; i > 0; i-- )
    {
        if ( j > 0 )
        {
            temp = a[i-1] + b[j-1] + flg - 96;
            j--;
        }
        else temp = a[i-1] + flg - 48;
        if ( temp >= 10 )
        {
            flg = 1;
        }
        else flg = 0;
        temp = temp % 10;
        sum[i] = temp + 48;
    }
    if ( flg == 1 ) sum[0] = 49;
    i = 0;
    while ( i <= len_a )
    {
        if ( sum[i] != ' ' ) cout << sum[i];
        i++;
    }
    cout << endl;
}
int main()
{
    int N;
    while ( cin >> N )
    {
        for ( int i = 1; i <= N; i++ )
        {
            char a[1000];
            char b[1000];
            cin >> a;
            cin >> b;
            int len_a = strlen ( a );
            int len_b = strlen ( b );
            cout << "Case " << i << ":\n" << a << " + " << b << " = ";
            if ( len_a >= len_b )
            {
                add ( a, b );
            }
            else add ( b, a );
            if ( i != N ) cout << endl;
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章