POJ2352樹狀數組

拿到這道題以及開始做的過程中,突然明白,樹狀數組的基礎我還沒弄明白,對諸位初學者說一聲,一定要將理論弄明白,否則真的很坑

題意:給出一些星星的座標,求出每個等級的星星有多少個(星星的等級等於它左下角的星星數之和。

解題思路:典型的樹狀數組問題,由題意可知Y是升序輸入,故我們只操作座標X,對X而言,因爲第一個星星的座標可以從0開始,故在更新樹狀數組的時候,要先++x;然後由getsum()函數求出等級,++veal[sum]完成每個等級星星數的統計

函數update是將出現過星星的地方加1,刷新整個樹狀結構

函數getsum是得到一個區間和,在本題中,這個區間和就是星星的等級數

B - Stars
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0


現給出AC代碼

#include<cstdio>
#include<string.h>
using namespace std;
const int MAX = 32000+10;
int c[MAX];
int veal[MAX];
int M,N,X,Y;

int lowbit(int i)
{
    return i & (-i);
}
void updata(int x)
{
    while(x < MAX)
    {
        ++c[x];
        x += lowbit(x);
    }
}
int getsum(int x)
{
    int ans = 0;
    while(x > 0)
    {
        ans += c[x];
        x -= lowbit(x);
    }
    return ans;
}

int main()
{
    int sum;
   scanf("%d",&N);
   M = N;
   memset(c,0,sizeof(0));
   memset(veal,0,sizeof(0));
  while(N--)
   {
        scanf("%d%d",&X,&Y);
       ++X;
       updata(X);
       sum = getsum(X);
        ++veal[sum];
   }
   for(int i = 1; i <=  M; i++)
   {
       printf("%d\n",veal[i]);
   }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章