hud1114 完全揹包 題解

   剛學了揹包,今天又看了完全揹包,非常興奮的就去做了一道題,現將題解分享給跟我一樣的小菜鳥~

   題意分析:現有一個重量爲E的存儲罐,要求裝滿後重量達到F。裏面有N種硬幣,每種硬幣的質量和價值分別爲P,W,現求出儲存罐裝滿後,可能的最小价值。

傳統揹包問題中往往是求解揹包裝滿後的最大價值。這需要我們的逆向思維,由max  轉化爲 min

注意:題目要求的是在儲存罐裝滿的情況下,故需要關注一下初始化問題

有兩個重要數組:

dp[i] :存儲罐的容量爲I時,所裝的硬幣容量是否也爲i(你最多能裝多少是由w[i]決定的)

初始化 爲零


ser[i] :重量爲i時的價值

ser[0]=0,其餘初始化爲正無窮大


狀態轉移方程

dp[ j ]=max(dp[j],dp[j-w[i]]+w[i]);對重量的監控

ser[ j ] = min(ser[j],ser[j-w[i]]+P[i])//對價值的監控

題目如下:

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10078    Accepted Submission(s): 5078


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.




現給出AC代碼

 

#include <iostream>
#include<string.h>
#include<cstdio>
using namespace std;
const int MAX = 10000+10;
const int index = 500 + 20;
int P[index];
int W[index];
int dp[MAX];
int res[MAX];
int T,E,F,N;
int main()
{
    scanf("%d",&T);
    int i,j;
    while(T--)
    {
        //求出最大的重量(符合要求的重量或是規定的重量)
        memset(dp,0,sizeof(dp));
        memset(res,0x3f,sizeof(res));//賦值無窮大
        res[0]=0;                //當儲存罐裏的錢是0的時候,最小价值也爲0
        scanf("%d%d",&E,&F);
        int ans = F-E;
        scanf("%d",&N);
        for(int i = 1; i <= N; i++)
        {
            scanf("%d%d",&P[i],&W[i]);
        }
        for(i = 1; i <= N; i++)
        {
            for(j = W[i]; j <= ans; j++)
            {
                dp[j] = max(dp[j],dp[j-W[i]] + W[i]);
                res[j]=min(res[j],res[j-W[i]]+P[i]);
            }
        }
        if(dp[ans] == ans)
        {
           printf("The minimum amount of money in the piggy-bank is %d.\n",res[ans]);
        }
        else
        {
            cout << "This is impossible." << endl;
        }
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章